Problem
- Cannot connect to Halo Infinite’s multiplayer matchmaking because of the “No ping to our datacenters” error message.
Cause
This error message occurs when your network blocks one of our essential servers. This could be caused by a router, firewall, your ISP network, or network administrator. If you use an enterprise-level network, for example a college dormitory, you may need to contact your IT/network administrator.
The following workarounds apply to both Xbox consoles and PC.
Possible workaround 1: Open Port 3075
Open port 3075 (UDP) on your router, as well as all required ports for the Xbox network. Required Xbox ports and instructions on how to open ports can be found in Xbox Support’s Network ports article.
There are further instructions in Advanced NAT troubleshooting (single console).
Possible workaround 2: Contact ISP or network administrator(s)
If you are unable to open the required ports or you do not have administrator privileges on your network, please contact your network administrator or internet service provider (ISP) and ask for Port 3075 to be unblocked.
Halo Support is unable to troubleshoot network issues, unblock port 3075, or escalate the issue with your network administrator(s).